Ultima versione
Versione stabile:
3.1.5
 
Servizi
» Cerca
 
Cerca
Ricerca parole o frasi all’interno del sito.
 
Statistiche
Visite: 195349
 
Donazioni
Flatnuke e' software libero ed e' distribuito grautitamente. Se pensi che flatnuke ti sia stato in qualche modo di aiuto, puoi contribuire con una donazione libera:

Vuoi saperne di piu'?

 
Login





Non sei ancora registrato?
Registrati ora!
Recupera password
Choose your language:
deutsch english espa?ol fran?ais italiano portugu?s
 
Utenti
Persone on-line:
admins 0 amministratori
users 0 utenti
guests 2 ospiti
 
Netsons Ads

Forum



Benvenuto sconosciutoModifica profiloEntraAiuto 1106 utenti registrati

Navigazione:

[ Forum / Flatnuke / Web compliance / Explorer/javascript 2.5.9 ]


UtenteMessaggio
kamaludu
kamaludu

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Mercoledi 11 Aprile 2007 23:23:55

Explorer/javascript 2.5.9

Salve, nuovo topic perche' mi pare una roba diversa rispetto al post di clarissa: dicevo che nella 2.5.9 con explorer si presentava questo errore

Riga: 49
Carattere: 2
Errore: Necessario oggetto
Codice: 0
URL: http://qualsiasi_pagina_del_sito

il problema sta' nel file:
/include/javascripts/preview.js

/*46	addLoadEvent(function(){*/

(l'ho messo tra commenti x evitare casini sul forum)
che andrebbe cosi
/*46	function addLoadEvent(){*/


uhm non vorrei pensaste che mi diverto a fare il pidocchioso: capita che giochi un po' con FN, capita che trovi un problema, capita che lo risolva, se mi pare valga la pena lo dico, punto
poi questa roba qui e' un inezia ... di quelle che, con un po' di sfiga, fanno perdere un sacco di tempo prima di trovarle

bye
Mosfet
Mosfet

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Mercoledi 11 Aprile 2007 23:47:00

Re: Explorer/javascript 2.5.9

Che versione hai scaricato della 2.5.9? perche' non mi sembra di vedere il file preview.js... hai caricato qualche modulo di gestione immagini in particolare?


---
Mosfet

--
Mosfet
kamaludu
kamaludu

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Mercoledi 11 Aprile 2007 23:53:33

Re: Explorer/javascript 2.5.9

l'ultima, cioe: flatnuke-2.5.9-20070406.tar.gz del 06/04/2007 da qui
http://flatnuke.sourceforge.net/nightly/
path: include/javascripts/preview.js

marcosegato
marcosegato

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Giovedi 12 Aprile 2007 08:58:49

Re: Explorer/javascript 2.5.9

Uhm... ? un errore che non capisco: la funzione addLoadEvent ? gi? definita in header.php
// Let overload window.onload function
function addLoadEvent(func) {

Non ? che piuttosto il file /include/javascripts/preview.js deve essere modificato in
addLoadEvent(function nomefunzione(){
???

---
Linux Registered User 265651 Powered by Slackware GNU/Linux

--
Linux Registered User 265651
marcosegato
marcosegato

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Giovedi 12 Aprile 2007 19:15:51

Re: Explorer/javascript 2.5.9

Ecco la documentazione della funzione: http://simonwillison.net/2004/May/26/addLoadEvent/

---
Linux Registered User 265651 Powered by Slackware GNU/Linux

--
Linux Registered User 265651
kamaludu
kamaludu

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Sabato 14 Aprile 2007 08:58:13

Re: Explorer/javascript 2.5.9

Ciao, scusate se non vi ho ancora risposto, appena mi e' possibile vedo di mettermi un po' davanti a questa cosa :)

bye
kamaludu
kamaludu

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Domenica 15 Aprile 2007 16:48:18

Re: Explorer/javascript 2.5.9

ciao, c'ho un po' guardato e confermo che non ci sono santi, a quanto pare ie questa roba qui non la vuole:
addLoadEvent(function(){
tooltip = (ns4)? document.fnpreview.document: (ie4)? document.all['fnpreview']: (ie5ns5)? document.getElementById('fnpreview'): null;
tipcss = (ns4)? document.fnpreview: tooltip.style;
if(dom && ns5) {
tipcss.position = 'fixed';
} else {
tipcss.position = 'absolute';
}
});


Uhm... ? un errore che non capisco: la funzione addLoadEvent ? gi? definita in header.php

si e' vero, correggendo come avevo fatto io probabilmente funzionava semplicemente perche' il codice qui sopra non veniva piu' valutato

Cmq a questo punto l'errore non lo capisco piu' manco io :( ... di errori nel codice non ne vedo, ho provato un po' a smanettare e riscriverlo in altri modi ma niente, non so che cosa voglia ie, non vuol sentir parlare di tooltip.style, so solo che x farlo smettere di lamentarsi tocca commentare tutta questa parte di codice in include/javascripts/preview.js
a sto punto ci vorrebbe un esperto javascript
ora devo troncare, ma sono veramente scocciato, che razza di cesso che e' ie grrr
se mi viene in mente qualcos'altro lo posto, ora come ora non ho nessuna idea

bye
marcosegato
marcosegato

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Domenica 15 Aprile 2007 18:17:16

Re: Explorer/javascript 2.5.9

Forse ho trovato:
// manage preview box position at window onload time
addLoadEvent(function(){
tooltip = (ns4)? document.fnpreview.document: (ie4)? document.all['fnpreview']: (ie5ns5)? document.getElementById('fnpreview'): null;
if(tooltip) {
tipcss = (ns4)? document.fnpreview: tooltip.style;
if(dom && ns5) {
tipcss.position = 'fixed';
} else {
tipcss.position = 'absolute';
}
}
});

L'errore si presentava in ogni pagina in cui non era definito un oggetto di nome "fnpreview" (utilizzato ad esempio per l'anteprima delle news, o per il box con le informazioni di copyright di alcuni moduli), quindi dovrebbe bastare il test sulla sua definizione.
Fatemi sapere, su Firefox non compare pi? la segnalazione d'errore nella console js.

---
Linux Registered User 265651 Powered by Slackware GNU/Linux

--
Linux Registered User 265651
kamaludu
kamaludu

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Domenica 15 Aprile 2007 21:44:25

Re: Explorer/javascript 2.5.9

Confermo che la correzione funziona anche con IE 6 SP2, ora niente + errori :D8)


print

Freely inspired to Mollio template