Ultima versione
Versione stabile:
3.1.5
 
Servizi
» Cerca
 
Cerca
Ricerca parole o frasi all’interno del sito.
 
Statistiche
Visite: 185359
 
Donazioni
Flatnuke e' software libero ed e' distribuito grautitamente. Se pensi che flatnuke ti sia stato in qualche modo di aiuto, puoi contribuire con una donazione libera:

Vuoi saperne di piu'?

 
Login





Non sei ancora registrato?
Registrati ora!
Recupera password
Choose your language:
deutsch english espa?ol fran?ais italiano portugu?s
 
Utenti
Persone on-line:
admins 0 amministratori
users 0 utenti
guests 1 ospiti
 
Netsons Ads

Forum



Benvenuto sconosciutoModifica profiloEntraAiuto 1106 utenti registrati

Navigazione:

[ Forum / Flatnuke / Flatnuke dev / bug dei caratteri accentati sul forum [RISOLTO] ]


UtenteMessaggio
Blue
Blue

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Martedi 22 Ottobre 2013 18:09:23

bug dei caratteri accentati sul forum

salve, sto usando flatnuke 3.1.2 e ho un problema nell'utilizzo del forum

praticamente quando nei messaggi vengono usati dei caratteri accentati il forum resituisce un messaggio bianco oppure un errore

stavo leggendo in un topic poco piu' in basso di questo dove si parlava di un bug simile ma anche applicando la correzione la cosa non funziona

come si potrebbe fare? nella versione in via di sviluppo e' gia' sistemato?

grazie tante per il supporto :)

--
never give up
Blue
Blue

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Domenica 27 Ottobre 2013 13:52:35

Re: bug dei caratteri accentati sul forum

per ora ho tolto del tutto htmlentities() e per quello che serve a me così funziona bene

--
never give up
bebabi34
bebabi34

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Venerdi 29 Novembre 2013 10:25:32

Ultima modifica di bebabi34 (Sabato 30 Novembre 2013 11:09:54)

Re: bug dei caratteri accentati sul forum

Blue ha scritto:
stavo leggendo in un topic poco piu' in basso di questo dove si parlava di un bug simile ma anche applicando la correzione la cosa non funziona
nella versione in via di sviluppo e' gia' sistemato?


nella versione 4 il passaggio a utf-8 eliminerà il problema.
ma mi pareva di averlo sistemato anche nella 3 (futura 3.1.3) con l'aggiunta della parte in rosso indicata nel post, che va aggiunta a tutte le occorrenze della funzione htmlentities del file forum/include/ff_functions.php
riga 1239
$body = htmlentities($body,ENT_COMPAT,_CHARSET);
righe 1506 e 1613
$ffbody = strip_tags(htmlentities(getparam("ffbody",PAR_POST,SAN_NULL),ENT_COMPAT,_CHARSET));

se hai fatto queste aggiunte e ancora ricevi errori, tienici informati.

EDIT
sostituito ISO-8859-1 con la più corretta _CHARSET
Blue
Blue

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Giovedi 05 Dicembre 2013 09:35:18

Re: bug dei caratteri accentati sul forum

grazie, per ora ho risolto.

aspetterò la versione 4 ;)

--
never give up
bebabi34
bebabi34

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Venerdi 20 Dicembre 2013 16:44:45

Re: bug dei caratteri accentati sul forum

hai risolto come indicato qui sopra o hai dovuto modificare altro?
bebabi34
bebabi34

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Sabato 26 Aprile 2014 17:24:41

Re: bug dei caratteri accentati sul forum

...sarebbe molto utile saperlo, grazie.
Blue
Blue

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Sabato 26 Aprile 2014 17:42:29

Re: bug dei caratteri accentati sul forum

Blue ha scritto:
per ora ho tolto del tutto htmlentities() e per quello che serve a me così funziona bene

avevo risolto, per quella versione che era distrubuita nel momento in cui ho scritto, rimuovendo questa funzione completamente dal codice

in questo modo c'erano altri problemi di visualizzazione (se ricordo bene con i tag html) ma gli accenti si potevano scrivere

tuttavia, con la nuova versione che ho prontamente scaricato e con cui ho aggiornato il sito, il file php in questione è stato sostituito del tutto e con questa nuova versione non mi sembra ci sia nessun problema

in questo momento non saprei dire che cosa è cambiato nel codice perché il file non l'ho confrontato quando ho eseguito l'aggiornamento, ma visto che ora funziona tutto non mi sono fatto molti problemi

--
never give up
bebabi34
bebabi34

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Sabato 26 Aprile 2014 21:15:13

Re: bug dei caratteri accentati sul forum

ok, grazie mille per i dettagli.


print

Freely inspired to Mollio template