Ultima versione
Versione stabile:
3.1.5
 
Servizi
» Cerca
 
Cerca
Ricerca parole o frasi all’interno del sito.
 
Statistiche
Visite: 198021
 
Donazioni
Flatnuke e' software libero ed e' distribuito grautitamente. Se pensi che flatnuke ti sia stato in qualche modo di aiuto, puoi contribuire con una donazione libera:

Vuoi saperne di piu'?

 
Login





Non sei ancora registrato?
Registrati ora!
Recupera password
Choose your language:
deutsch english espa?ol fran?ais italiano portugu?s
 
Utenti
Persone on-line:
admins 0 amministratori
users 0 utenti
guests 4 ospiti
 
Netsons Ads

Forum



Benvenuto sconosciutoModifica profiloEntraAiuto 1106 utenti registrati

Navigazione:

[ Forum / Flatnuke / Flatnuke dev / newslist buggato [CORRETTO] ]

Vai alla pagina:
  > >>

UtenteMessaggio
ZEBDEMON
ZEBDEMON

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Sabato 29 Ottobre 2011 23:53:01

newslist buggato

il file newslist setta la prima news come vuota e quindi in home si vedrà sempre una news in meno, cioè, se impostate che volete vedere 5 news in home, in realtà ne vedrete 4 perchè la prima non esiste.

--
..Stand Tall & Shake the Heavens..
marcosegato
marcosegato

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Domenica 30 Ottobre 2011 14:34:01

Re: newslist buggato

Con "file newslists" cosa intendi di preciso?
Sul mio sito personale anche io ho il problema di visualizzzare in homepage una notizia in meno di quanto parametrizzato, invece qui sul sito ufficiale il comportamento è corretto... bisogna indagare meglio.
Per caso hai già dato uno sguardo per correggere il problema?

--
Linux Registered User 265651
ZEBDEMON
ZEBDEMON

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Domenica 30 Ottobre 2011 16:54:16

Re: newslist buggato

marcosegato ha scritto:
Con "file newslists" cosa intendi di preciso?
Sul mio sito personale anche io ho il problema di visualizzzare in homepage una notizia in meno di quanto parametrizzato, invece qui sul sito ufficiale il comportamento è corretto... bisogna indagare meglio.
Per caso hai già dato uno sguardo per correggere il problema?


no, sono stato molto impegnato con l'aggiornamento del mio sito.

cmq il file newslist è il file con la lista di tutte le news, viene aggiornato ad ogni news aggiunta/rimossa. solo che il primo elemento della lista è sempre vuoto, ergo, un elemento in meno nella prima pagina.

si trova qui: /sections/none_News/none_newsdata/newslist.php

provo a dargli un'occhiata..

--
..Stand Tall & Shake the Heavens..
ZEBDEMON
ZEBDEMON

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Domenica 30 Ottobre 2011 17:52:21

Re: newslist buggato

è normale che (file newsfunctions.php funzione list_news):

$important_news = glob(get_news_dir($section)."/top_*.fn.php");


restituisca un boolean? O.o
(tra l'altro mi chiedo se serva lo slash prima di top. get_news_dir non restituisce lo slash finale?).

cmq l'errore sta li, in quanto nonostante non ci sono notizie importanti, si va a finire dentro al ciclo:

if (count($important_news)>0){


che setta un elemento vuoto all'array $isortednews e quindi di conseguenza ci ritroviamo l'elemento vuoto nel newslist.

--
..Stand Tall & Shake the Heavens..
marcosegato
marcosegato

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Martedi 01 Novembre 2011 12:54:27

Re: newslist buggato

Ho fatto un po' di prove, sia su installazioni nuove che su aggiornamenti, ed il problema non si verifica più.
A questo punto sono portato a pensare che si tratti di un errore che era presente nelle versioni beta ed ora è risolto.
Ho eliminato a mano quell'elemento vuoto e si è risolto tutto.

--
Linux Registered User 265651
aldoboccacci
aldoboccacci

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Martedi 01 Novembre 2011 13:35:12

Re: newslist buggato

Soluzione spiccia spiccia: inserire un controllo sull'esistenza del file in fase di caricamento (o ancora meglio di salvataggio) e sull'esistenza del valore che si sta salvando.

--
risorse per flatnuke: http://www.aldoboccacci.it
ZEBDEMON
ZEBDEMON

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Martedi 01 Novembre 2011 17:03:08

Re: newslist buggato

marcosegato ha scritto:
Ho fatto un po' di prove, sia su installazioni nuove che su aggiornamenti, ed il problema non si verifica più.
A questo punto sono portato a pensare che si tratti di un errore che era presente nelle versioni beta ed ora è risolto.
Ho eliminato a mano quell'elemento vuoto e si è risolto tutto.


anche io avevo eliminato la riga vuota ma si ripresenta. ed uso la 3.0 stable installata pulita da zero. ripeto, è normale che glob restituisca un boolean? false>0 fa entrare dentro al ciclo e quindi il primo elemento viene settato (in quanto la variabile inews è vuota).

mi perdo qualcosa?

--
..Stand Tall & Shake the Heavens..
ZEBDEMON
ZEBDEMON

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Jabber Skype
Martedi 08 Novembre 2011 15:30:17

Re: newslist buggato

tra l'altro a causa del bug mi ritrovo l'anno 1970 in archivio news :(

cmq ad ogni modifica di una news riappare il tag vuoto!
ho installato la 3.0.0 pulita e non è beta.

--
..Stand Tall & Shake the Heavens..
Doc
Doc

0
10
Livello 0

levellevellevellevellevellevellevellevellevellevel
profile home page
Mercoledi 09 Novembre 2011 06:15:24

Re: newslist buggato

ZEBDEMON ha scritto:
tra l'altro a causa del bug mi ritrovo l'anno 1970 in archivio news

cmq ad ogni modifica di una news riappare il tag vuoto!
ho installato la 3.0.0 pulita e non è beta.

stessa identica cosa...

--
Doc
bebabi34
bebabi34

0
10
Livello 10

levellevellevellevellevellevellevellevellevellevel
profile home page
Skype
Martedi 18 Giugno 2013 15:29:17

Re: newslist buggato

perchè INVALID ?
ho fatto da windows una installazione pulita della 3.1.1 su altervista e ho riscontrato tuttora questo problema.
in una installazione locale pulita su linux non compare, nè è mai comparso sulla mia installazione su aruba (sempre da linux).
faccio qualche prova, poi controllo, poi vi dico...

Vai alla pagina:
  > >>

print

Freely inspired to Mollio template